开启左侧

halcon 17 与halcon 10 怎么兼容在同一个软件内,求大佬指导??

[复制链接]
youweijinyi 发表于 2022-11-3 17:37:27 | 显示全部楼层 |阅读模式
halcon 17 与halcon 10 怎么兼容在同一个软件内,求大佬指导??
Criss 发表于 2022-11-3 20:57:10 | 显示全部楼层
一般高版本是向下兼容的,直接用最高的版本语法改写程序即可
 楼主| youweijinyi 发表于 2022-11-4 08:11:00 | 显示全部楼层
Criss 发表于 2022-11-3 20:57
一般高版本是向下兼容的,直接用最高的版本语法改写程序即可

公司软件用了十年了,以前额通用算法工具 都是10写的,全部替换工作量有点大,现在想这用高版本halcon 了  想着在C++软件里 怎么兼容 高版本
Criss 发表于 2022-11-4 11:36:12 | 显示全部楼层
youweijinyi 发表于 2022-11-4 08:11
公司软件用了十年了,以前额通用算法工具 都是10写的,全部替换工作量有点大,现在想这用高版本halcon 了 ...

没办法的,这种兼容性到后面更难维护,要么统一用低版本要不全部升级高版本,兼容的代价非常高。
yongjiu 发表于 2022-11-4 14:30:27 | 显示全部楼层
这种兼容性到后面更难维护,要么统一用低版本要不全部升级高版本
您需要登录后才可以回帖 登录 | 注册

本版积分规则

快速回复 返回顶部 返回列表