51Halcon机器视觉

 找回密码
 会员注册

QQ登录

只需一步,快速开始

扫一扫,微信登录

查看: 244|回复: 1

[已解决] LMI相机运行一段时间就掉线问题分析和解决方案

[复制链接]
  • TA的每日心情
    开心
    昨天 16:20
  • 签到天数: 810 天

    连续签到: 20 天

    [LV.10]以坛为家III

    363

    主题

    1477

    帖子

    6383

    积分

    Rank: 9

    积分
    6383

    突出贡献优秀版主荣誉管理论坛元老切换助手验证会员最佳新人

    发表于 2019-11-16 23:37:15 | 显示全部楼层 |阅读模式

    51Halcon诚邀您的加入,专注于机器视觉开发与应用技术,我们一直都在努力!

    您需要 登录 才可以下载或查看,没有帐号?会员注册

    x
    背景:客户现场已经架设好了Gocator线激光23xx系列,连接用的千兆路由器和六类屏蔽网线,网速可以达到1.0Gbps,图像正常,运行一段时间后就会提示-986错误,这个错误按照官方解释是网络异常。
    重现:既然觉得是网络异常,所以赶紧重新更换网线和交换机,同时固定好相机,然后测试200多次没有问题,自以为正常了。接下来,到了后面整个机器拉去展会,布线当天测试,就有不稳定情况出现,比如运行20次扫描图像后就开始掉线错误,直到后来扫一次掉一次,重新启动软件又可以正常工作,我的妈呀啥情况啊?
    分析:网线正常,交换机正常,网卡设置了巨帧9K和全双工(这里要说明的是,有的不是单独的PCIE网卡,用的USB那种转的,这个时候网卡里面是没有巨帧的,根据说明书,要开启双工后会自动进入千兆工作模式),还是会偶尔出现该问题。经过推敲,硬件应该是好的,目前得到数据可以判定大概率在相机到交换机的网线部分,软件重启又可以,说明不是硬件有缺陷,那很有可能有其他干扰,赶紧咨询了下厂家,厂家负责人说可能是有干扰导致网络链路不稳定,这。。。,想了下赶紧联系电工师傅,同时打开接线图和师傅确认,发现屏蔽网和GND部分没有接入到机壳和接地,赶紧让师傅改下线路。。。中间省略。。。,后面重新测试,好像没有出现了,抱着怀疑态度,展会当天全天跟着,同时开着DebugView跟踪控制台打印的监控数据,果然这个问题再也没有出现 ,尴尬了。最后成功解决了这个问题,虽然不是软件解决,同时也发现了要想视觉系统运行正常,整个机器视觉系统都要了解,不然就是挖坑填自己啊!

    仅以此分享给大家,希望大家学会分析此类问题,避免走弯路,晚安!
    无效附件更新 权限提升操作 删帖申请 举报以及其他需要帮助请加入QQ群:214663141 广告位招商 有意者联系
    您需要登录后才可以回帖 会员登录 | 会员注册

    本版积分规则

    51Halcon会员技术交流会员技术交流 | 51Halcon官方客服咨询官方客服咨询 | Halcon切换助手使用反馈切换助手使用反馈 | 51Halcon论坛管理团队论坛管理团队

    申请友链| 小黑屋| 手机版| Archiver|  

    粤ICP备15095995号-2 粤公网安备44030602000670号

    CopyRight © 2015-2020 51Halcon机器视觉. Tencent Cloud X3.4.

    快速回复 返回顶部 返回列表